当前位置:→ 乐天使fun88网通达信公式 → 正文
  • 通达信涨跌停、吃面、撬板编写及主图公式

  • 相关简介:通达信涨跌停、吃面、撬板编写及主图公式 {通达信自带的张跌停计算函数,其实很好用!只要灵活使用简单的判别语句,就可以将主图做的一目了然!} {现在的涨跌停计算复杂了些,但用好判别语句,也很简单!} {例如涨跌幅计算完全可以这么写}

  • 文章来源:佚名发布时间:2021-05-09浏览次数:下载次数:61收藏:

通达信涨跌停、吃面、撬板编写及主图公式
{通达信自带的张跌停计算函数,其实很好用!只要灵活使用简单的判别语句,就可以将主图做的一目了然!}
{现在的涨跌停计算复杂了些,但用好判别语句,也很简单!}
{例如涨跌幅计算完全可以这么写}

源码如下:

涨跌幅:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('创业板')AND DATE>=1200823,0.2,IF(INBLOCK('ST板块'),0.05,0.1)));
{新股上市,创业板和科创板不限涨跌幅度,那么就从第六个交易日开始计算好了!}
上市超过5日:=BARSCOUNT(CLOSE)>=5;
{适当除去ST以及停牌股}
正常股:=IF(NAMELIKE('*ST'),0,1) AND IF(NAMELIKE('*'),0,1) AND IF(NAMELIKE('S'),0,1)  AND DYNAINFO(17)>0;
{涨停板和跌停板要考虑买一卖一}
买一无量:=DYNAINFO(58)=0;
卖一无量:=DYNAINFO(59)=0;
{1.今日涨停}
涨停:=C>=ZTPRICE(REF(C,1),涨跌幅) AND C=H AND 上市超过5日 AND 正常股 AND 卖一无量;
{2.今日跌停}
跌停:=C<=DTPRICE(REF(C,1),涨跌幅) AND C=L AND 上市超过5日 AND 正常股 AND 买一无量;
{3.吃面}
吃面:=H>=ZTPRICE(REF(C,1),涨跌幅) AND C<H AND 上市超过5日;
{4.撬板}
撬板:=L<=DTPRICE(REF(C,1),涨跌幅) AND C>L AND 上市超过5日;
昨日涨停:=ref(涨停,1);
首板:=BARSLASTCOUNT(涨停)=1;
二连板:=BARSLASTCOUNT(涨停)=2;
连板:BARSLASTCOUNT(涨停)>=2;



下载链接:( 说明:乐天使fun88资源如需解压密码的请输入本站域名:www.52gfogq.com 请仔细输入!)
点击下载资源无反应,请更换浏览器操作(如IE、Chrome浏览器)将乐天使fun88网设置信任,不要阻止乐天使fun88网弹出!
涨跌停主图-20210509214526.tn6资源大小:7.11KB , 免费下载

通达信涨跌停、吃面、撬板编写及主图公式

  • 下载资源所需积分

    0

  • 当前拥有积分

    0

乐天使fun88网粉丝必读
公式解密、改选股联系QQ:78858997(有偿服务)点击查看详情...
乐天使fun88网指标公式帮助使用说明!新手必读...
乐天使fun88网新系统使用说明!新手必读...
乐天使fun88网VIP用户组必读...
说说看法 0
推荐资源

关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - SiteMap - TOP
Copyright © 2020 铭网科技,All Rights Reserved.
本站所有广告和与乐天使fun88网均无关系,请股友自行判断真假!乐天使fun88网客服QQ:78858997
乐天使fun88网乐天使fun88软件下载中心
乐天使fun88网乐天使fun88书籍下载中心