未来函数检测 | 推荐资源 | 热门资源 fun88平台搜索 | 收藏fun88平台网 | 将fun88平台网放到桌面
fun88平台网,最好fun88平台软件下载中心,fun88平台软件,fun88平台书籍,fun88平台公式,fun88平台知识,
fun88平台首页 | 指标公式 | 分析软件 | 行情软件 | 数据软件 | 资讯题材 | 工具应用 | 期货基金 | 书籍教程 | 技术指标 | fun88平台宝贝 | 外汇期货 | fun88靠谱知识 |
fun88靠谱软件 大智慧 通达信 飞狐 东财通 操盘手 指南针 同花顺 钱龙 券商软件 手机炒股 和谐软件 证券之星 金融界 分析家 数据下载 数据接口 期货 基金 教程
fun88靠谱公式 大智慧 通达信 飞狐 同花顺 东财通 | fun88靠谱池 大智慧 通达信 | fun88靠谱书籍 | 指标分解 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ WR CR
当前位置:→ fun88平台网 > 指标公式 > 通达信公式 > 正文
  • 通达信分时主图强大实用手机电脑端可用公式主图源码

  • 简介:非原创,自己一直在使用,公式网上搜集回来自己优化修改过。 提供手机端和电脑端的源码。 {分时主图手机} MA30:=EMA(CLOSE,30); 强弱:=EMA(CLOSE,900); H1:=MAX(DYNAINFO(3),DYNAINFO(5)); L1:=MIN(DYNAINFO(3),DYNAINFO(6)); P1:=H1-L1; 阻力:L1+P1*7/8,COLORLIMAGENTA,DOTLINE; 支撑:L1+P1*0.5/8,COLORCYAN,DOTLINE; 中:(支撑+
  • 来源:Internet 时间:20-05-08 点击: 下载:

 fun88平台网指标公式帮助说明 新手必读

非原创,自己一直在使用,公式网上搜集回来自己优化修改过。

提供手机端和电脑端的源码
 

 

{分时主图手机}

 

MA30:=EMA(CLOSE,30);

强弱:=EMA(CLOSE,900);

H1:=MAX(DYNAINFO(3),DYNAINFO(5));

L1:=MIN(DYNAINFO(3),DYNAINFO(6));

P1:=H1-L1;

阻力:L1+P1*7/8,COLORLIMAGENTA,DOTLINE;

支撑:L1+P1*0.5/8,COLORCYAN,DOTLINE;

中:(支撑+阻力)/2,COLORBLUE,POINTDOT;

现价:=CLOSE,COLORWHITE,LINETHICK3;

{DRAWTEXT(ISLASTBAR AND 现价,现价,STRCAT('-',CON2STR(现价,2))),COLORYELLOW;}

MZ0:=(BARSLAST(((HOUR=9) AND (MINUTE=31)))+1);

上穿分时:IF(((SETCODE<2) AND (CONST(MZ0)<241)),CONST(IF((TIME<1000),HHV(CLOSE,0),SUM((IF((TIME=1000),1,0)*HHV(CLOSE,0)),0))),DRAWNULL),LINETHICK1,COLORLIRED;

底支:IF(((SETCODE<2) AND (CONST(MZ0)<241)),CONST(IF((TIME<1000),HHV(CLOSE,0),SUM((IF((TIME=1000),1,0)*LLV(CLOSE,0)),0))),DRAWNULL),LINETHICK1,COLORLIGREEN;

STICKLINE(TIME=931 OR TIME=1000,上穿分时,底支,0,-1),COLORLIBLUE;

分时上突:=CROSS(C,上穿分时);上突:=C<上穿分时 AND 上穿分时>底支;

股价支撑线:=MA(CLOSE,20);

VAR106:=BARSCOUNT(CLOSE);

VAR107:=MAX(DYNAINFO(3),DYNAINFO(5));

VAR108:=MIN(DYNAINFO(3),DYNAINFO(6));

VAR109:=VAR107-VAR108;

VAR110:=VAR108+VAR109*7/8;

VAR111:=VAR108+VAR109*0.5/8;

DRAWICON(LONGCROSS(VAR111,CLOSE,2),CLOSE,1);

DRAWICON(LONGCROSS(CLOSE,VAR110,2),CLOSE,2);

双轨线上强势:0,COLORRED,NODRAW;

双轨线下弱势:0,NODRAW,COLORFF9900;

把握疯牛卖点:0,NODRAW,COLOR00FF00;

HH:=(H+C)/2;

LL:=(L+O)/2;

三日均高:=(H+REF(H,2)+REF(H,3))/3;

三日收盘:=(C+REF(C,2)+REF(C,3))/3;

强势线:EMA((三日均高+三日收盘)/2,7),COLORRED,LINETHICK2;

支撑线:EMA((LL+REF(LL,2)+REF(LL,3))/3,7),COLOR00FF00,LINETHICK2;

IF(强势线>REF(强势线,1),强势线,DRAWNULL),LINETHICK2,COLORRED;

IF(强势线<REF(强势线,1),强势线,DRAWNULL),LINETHICK2,COLORGREEN;

IF(支撑线>REF(支撑线,1)*0.997,支撑线,DRAWNULL),LINETHICK4,COLORRED;

IF(支撑线<REF(支撑线,1)*0.997,支撑线,DRAWNULL),LINETHICK4,COLORGREEN;

量比:=DYNAINFO(17),NODRAW;

涨幅:=(CLOSE/DYNAINFO(3))>=1.005 AND (CLOSE/DYNAINFO(3))<=1.04;

涨幅1:=(CLOSE/DYNAINFO(3))>=1.005 AND (CLOSE/DYNAINFO(3))>=1.05;

收盘涨幅:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;

A1:=NAMELIKE('ST');

A2:=NAMELIKE('*');

A3:=NAMELIKE('S');

去除ST:=(A1+A2+A3)=0;

冲高减仓:=C>=HHV(H,60) AND 涨幅1 AND 量比<2 AND CLOSE/DYNAINFO(3)<9 AND 去除ST ,NODRAW;

VAR3:=REF(CLOSE,1);

VAR4:=(SMA(MAX(CLOSE-VAR3,0),6,1))/(SMA(ABS(CLOSE-VAR3),6,1))*100;

追涨:=CROSS(85,VAR4) AND 涨幅;

高抛:=CROSS(VAR4,80) AND 涨幅1 AND 量比<2;

DRAWTEXT(追涨,L*0.985,'强势'),COLORYELLOW;

DRAWTEXT(COUNT(冲高减仓,3)>=1 AND 收盘涨幅<2 AND C>强势线*1.12,H*1.01,'卖'),COLORGREEN;

上穿双轨:=(CROSS(C,强势线) AND CROSS(C,支撑线)) OR (支撑线>REF(支撑线,1) AND L<支撑线 AND C>强势线) OR REF(CROSS(C,支撑线),1)=1 AND CROSS(C,强势线);

双穿卖出:=(CROSS(强势线,C) AND CROSS(支撑线,C)) OR ( (C<支撑线 AND H>强势线) OR (REF(H,1)>强势线 AND CROSS(支撑线,C)));

STICKLINE(上穿双轨 ,OPEN,CLOSE,3.3,0),COLOR0055FF;

STICKLINE(上穿双轨,OPEN,CLOSE,3.3,0),COLOR0077FF;

STICKLINE(上穿双轨 ,OPEN,CLOSE,3,0),COLOR0099FF;

STICKLINE(上穿双轨,OPEN,CLOSE,2.2,0),COLOR00BBFF;

STICKLINE(上穿双轨,OPEN,CLOSE,1.5,0),COLOR00DDFF;

STICKLINE(上穿双轨,OPEN,CLOSE,0.4,0),COLOR00FFFF;

{STICKLINE(双穿卖出,OPEN,CLOSE,3.3,0),COLOR00FF00;};

DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);

卖一:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);

量价:=(VOL/CLOSE)/3;

A22:=SUM((IF(((量价>0.20) AND (CLOSE>(REF(CLOSE,1)))),量价,0)),0);

A33:=SUM((IF(((量价>0.20) AND (CLOSE<(REF(CLOSE,1)))),量价,0)),0);

A66:=A22+A33;

DD1:=1;

比:=A22/A33;

AAA1:=STRCAT(STRCAT('买= ',CON2STR((100*A22)/A66,0)),'%');

AAA2:=STRCAT(STRCAT('卖= ',CON2STR((100*A33)/A66,0)),'%');

AAA3:=STRCAT(STRCAT('差= ',CON2STR((100*(A22-A33))/A66,0)),'%');

DRAWTEXT_FIX(DD1=1,0.4,0.7,0,AAA1),COLORRED;

DRAWTEXT_FIX(DD1=1,0.6,0.7,0,AAA2),COLORGREEN;

DRAWTEXT_FIX(DD1=1,0.8,0.7,0,AAA3),COLOR00FFFF;

DRAWTEXT_FIX(比>2,0,0.40,0,'涨'),COLORCYAN;

DRAWTEXT_FIX(比>2,0,0.48,0,'停'),COLORMAGENTA;

DRAWTEXT_FIX(比>2,0,0.56,0,'板'),COLORRED;

中期线:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4)+100;

DRAWTEXT(比<1.1,(DYNAINFO(5)+DYNAINFO(6))/2,'。'),COLORGREEN;

DRAWTEXT(比>1.5,(DYNAINFO(5)+DYNAINFO(6))/2,'。'),COLORCYAN;

DRAWTEXT(比>2,(DYNAINFO(5)+DYNAINFO(6))/2,'。'),COLORMAGENTA;

DRAWTEXT(比>2.5,(DYNAINFO(5)+DYNAINFO(6))/2,'。'),COLORRED;

DRAWTEXT((比>1.1 AND 中期线<5),(DYNAINFO(5)+DYNAINFO(6))/2,'。'),COLORWHITE;

DRAWTEXT((比<1.1 AND 中期线>98.0),(DYNAINFO(5)+DYNAINFO(6))/2,'。'),COLORWHITE;

DRAWTEXT((比>1.1 AND 中期线<5),C,'买'),COLORYELLOW;

DRAWTEXT((比<1.1 AND 中期线>98.0),C,'卖'),COLORGREEN;
 

通达信分时主图强大实用手机电脑端可用公式主图源码

通达信分时主图强大实用手机电脑端可用公式主图源码

通达信分时主图强大实用手机电脑端可用公式主图源码

电脑版:
 

MA30:=EMA(CLOSE,30);

强弱:=EMA(CLOSE,900);

{-------------------------------------------------------------------------------------}

H1:=MAX(DYNAINFO(3),DYNAINFO(5));

L1:=MIN(DYNAINFO(3),DYNAINFO(6));

P1:=H1-L1;

阻力:L1+P1*7/8,COLORLIMAGENTA,DOTLINE;

支撑:L1+P1*0.5/8,COLORCYAN,DOTLINE;

中:(支撑+阻力)/2,COLORLIGRAY,POINTDOT;

均价:=SUM(V*C,0)/SUM(V,0),COLORYELLOW,DOTLINE;

现价:=CLOSE,COLORWHITE,LINETHICK1;

DRAWTEXT(ISLASTBAR AND 现价,现价,STRCAT('←',CON2STR(现价,2))),COLORYELLOW;

STICKLINE(CROSS(支撑,现价),支撑,中,0,-1),COLORYELLOW;

STICKLINE(CROSS(现价,阻力),阻力,中,0,-1),COLORGREEN;

DRAWTEXT(LONGCROSS(支撑,现价,2),C*0.9982,' 买'),COLORYELLOW;

DRAWTEXT(LONGCROSS(现价,阻力,2),C*1.0018,' 卖'),COLORCYAN;

STICKLINE(C<支撑,支撑,C,1,0),COLORYELLOW;

DRAWICON(CROSS(支撑,现价),(支撑-中)/5+支撑,26);

 

{DRAWICON(CROSS(现价,阻力),阻力-(支撑-中)/5,15);}

DRAWTEXT(CURRBARSCOUNT=8,阻力+0.003,'顶'),COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=8,支撑-0.003,'底'),COLORGREEN;

DRAWTEXT(CURRBARSCOUNT=8,(支撑+阻力)/2,'中'),COLORLIRED;

量价:=(VOL/CLOSE)/3;

A2:=SUM((IF(((量价>0.20) AND (CLOSE>(REF(CLOSE,1)))),量价,0)),0);

A3:=SUM((IF(((量价>0.20) AND (CLOSE<(REF(CLOSE,1)))),量价,0)),0);

A6:=A2+A3;DD1:=1;比:=A2/A3;

AAA1:=STRCAT(STRCAT('买= ',CON2STR((100*A2)/A6,0)),'%');

AAA2:=STRCAT(STRCAT('卖= ',CON2STR((100*A3)/A6,0)),'%');

AAA3:=STRCAT(STRCAT('差= ',CON2STR((100*(A2-A3))/A6,0)),'%');

中期线:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4)+100;

 

DRAWTEXT(比<1.1,中,'O'),COLORGREEN;

DRAWTEXT(比>1.5,中,'O'),COLORCYAN;

DRAWTEXT(比>2,中,'O'),COLORMAGENTA;

DRAWTEXT(比>2.5,中,'O'),COLORRED;

DRAWTEXT((比>1.1 AND 中期线<5),中,'O'),COLORWHITE;

DRAWTEXT((比<1.1 AND 中期线>98.0),中,'O'),COLORWHITE;

DRAWTEXT((比>1.1 AND 中期线<5),C,'-买'),COLORYELLOW;

DRAWTEXT((比<1.1 AND 中期线>98.0),C,'-卖'),COLORYELLOW;

{-------------------------------------------------------------------------------------}

均价1:=SUM(C*V,240)/SUM(V,240),COLORYELLOW,LINETHICK1;

TT:=BARSCOUNT(C);均:=MA(C,TT);

上均线:=均+2*STD(C,3);下均线:=均-2*STD(C,3);

时长:=TIME>93000;涨幅:=C/REF(C,1)>1.02;跌幅:=C/REF(C,1)<0.98;

横盘:=((HHV(C,TT)-LLV(C,TT))/C)<0.05;YY:=SMA(VOL,30,1);

放量:=(YY-LLV(LLV(YY,1),30))/(HHV(HHV(YY,1),30)-LLV(LLV(YY,1),30))>0.95;

涨跌幅:=涨幅 OR 跌幅;

横涨1:=涨跌幅=0 AND 横盘  AND 放量 AND CROSS(均价1,均);

DRAWTEXT(FILTER(横涨1,10),均价1,'--突破'),COLORCYAN;

DRAWICON(FILTER(横涨1,10),均价1,1);

 

XX:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));

主力:=EXPMA(CLOSE/XX,20);大户:=EXPMA(CLOSE/XX,60);散户:=EXPMA(CLOSE/XX,120);

底:=1;1.02,NODRAW;高:=1.03;

AA:=主力>大户 AND 主力>1.003 AND 大户>散户 AND C>EXPMA(C,20) AND EXPMA(C,10)>EXPMA(C,20) AND EXPMA(C,20)>EXPMA(C,60);

DRAWICON(主力>大户 AND 大户>散户 AND C>EXPMA(C,20) AND EXPMA(C,10)>EXPMA(C,20) AND EXPMA(C,20)>EXPMA(C,60) AND 主力=HHV(主力,30) AND CROSS(主力,1.003),C,25);

DRAWTEXT(主力>大户 AND 大户>散户 AND C>EXPMA(C,20) AND EXPMA(C,10)>EXPMA(C,20) AND EXPMA(C,20)>EXPMA(C,60) AND 主力=HHV(主力,30) AND CROSS(主力,1.003),C*0.999,'-主力'),COLORYELLOW;

DRAWICON(CROSS(主力,1.02),C,26);

DRAWTEXT(CROSS(主力,1.02),C*0.999,'-拉升'),COLORCYAN;

DRAWICON(CROSS(主力,1.04),C,24);

DRAWTEXT(CROSS(主力,1.04),C*0.999,'-冲涨停'),COLORLIMAGENTA;

DRAWICON(CROSS(散户,主力),C,6);

DRAWTEXT(CROSS(散户,主力),C*0.9995,'-小心'),COLORGREEN;

DRAWICON(CROSS(散户,大户),C,6);

DRAWTEXT(CROSS(散户,大户),C*0.9995,'-走弱'),COLORGREEN;

 

{-------------------------------------------------------------------------------------}

现手买:BUYVOL*DYNAINFO(7)*100/10000 COLOR0000FF,NODRAW;

现手卖:SELLVOL*DYNAINFO(7)*100/10000 COLOR00FF00,NODRAW;

合:=ABS(现手买)+ABS(现手卖)COLOR80FFFF,NODRAW;

差:=ABS(现手买)-ABS(现手卖)COLOR80FFFF,NODRAW;

MPB1:=ABS(现手买)/合*100;

MPB2:=ABS(现手卖)/合*100;

TESTSKIP(NOT(现手买 OR 现手卖 OR 合 OR 差 OR MPB1 OR MPB2)!=0);

DRAWRECTREL(595,1000,795,940,RGB(0,128,0));

DRAWRECTREL(595,995,795,945,RGB(0,148,0));

DRAWRECTREL(595,990,795,950,RGB(0,168,0));

DRAWRECTREL(595,985,795,955,RGB(0,188,0));

DRAWRECTREL(595,980,795,960,RGB(0,208,0));

DRAWRECTREL(595,975,795,965,RGB(0,228,0));

DRAWRECTREL(595,970,795,970,RGB(0,248,0));

DRAWRECTREL(595,1000,595+现手买*210/合,940,RGB(128,0,0));

DRAWRECTREL(595,995,595+现手买*210/合,945,RGB(148,0,0));

DRAWRECTREL(595,990,595+现手买*210/合,950,RGB(168,0,0));

DRAWRECTREL(595,985,595+现手买*210/合,955,RGB(188,0,0));

DRAWRECTREL(595,980,595+现手买*210/合,960,RGB(208,0,0));

DRAWRECTREL(595,975,595+现手买*210/合,965,RGB(228,0,0));

DRAWRECTREL(595,970,595+现手买*210/合,970,RGB(248,0,0));

DRAWRECTREL(595+现手买*210/合,940,595+现手买*210/合,1000,RGB(128,0,0));

DRAWRECTREL(795,940,795,1000,RGB(0,0.0,10));

DRAWRECTREL(594.8,939.8,594.8,1000,RGB(0,0,10));

DRAWRECTREL(594.8,939.8,594.8,939.8,RGB(0,0,10));

DRAWRECTREL(594.8,1000,594.8,1000,RGB(0,0,10));

DRAWTEXT_FIX(1,0.560,0.89,0,STRCAT(STRCAT('',CON2STR(现手买,1)),'万')),COLORRED;

DRAWTEXT_FIX(1,0.800,0.89,0,STRCAT(STRCAT('',CON2STR(现手卖,1)),'万')),COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(差)>0,0.678,0.888,0,STRCAT(' ',STRCAT(CON2STR(差,1),'万'))) COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(差)<0,0.678,0.888,0,STRCAT(' ',STRCAT(CON2STR(差,1),'万'))) COLORGREEN;

DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(差)=0,0.678,0.888,0,STRCAT(' ',STRCAT(CON2STR(差,1),'万'))) COLOR80FFFF;

DRAWTEXT_FIX(1,0.800,0.98,0,STRCAT(STRCAT(' ',CON2STR(MPB2,1)),'%')),COLORGREEN;

DRAWTEXT_FIX(1,0.560,0.98,0,STRCAT(STRCAT('',CON2STR(MPB1,1)),'%')),COLORRED;

{-------------------------------------------------------------------------------------}

D1:=YEAR AND MONTH AND DAY;

AA1:=STRCAT(CON2STR(YEAR,0),'年');

AA2:=STRCAT(CON2STR(MONTH,0),'月');

AA3:=STRCAT(CON2STR(DAY,0),'日');

AA4:=STRCAT('星期',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF(WEEKDAY=5,'五',IF(WEEKDAY=6,'六','日')))))));

AAC:=STRCAT(STRCAT(STRCAT(AA1,AA2),STRCAT(AA3,AA4)),'');

DRAWTEXT_FIX(D1,0.888,0.001,0,AAC),COLORLIGRAY;

{-------------------------------------------------------------------------------------}

MZ0:=(BARSLAST(((HOUR=9) AND (MINUTE=31)))+1);

上穿分时:IF(((SETCODE<2) AND (CONST(MZ0)<241)),CONST(IF((TIME<1000),HHV(CLOSE,0),SUM((IF((TIME=1000),1,0)*HHV(CLOSE,0)),0))),DRAWNULL),LINETHICK1,COLORLIRED;

底支:IF(((SETCODE<2) AND (CONST(MZ0)<241)),CONST(IF((TIME<1000),HHV(CLOSE,0),SUM((IF((TIME=1000),1,0)*LLV(CLOSE,0)),0))),DRAWNULL),LINETHICK1,COLORLIGREEN;

STICKLINE(TIME=931 OR TIME=1000,上穿分时,底支,0,-1),COLORLIBLUE;

分时上突:=CROSS(C,上穿分时);

上突:=C<上穿分时 AND 上穿分时>底支;

 

股价支撑线:=MA(CLOSE,20);

底价线:=股价支撑线-2*STD(CLOSE,20),COLORMAGENTA,LINETHICK2;

 

VAR106:=BARSCOUNT(CLOSE);

VAR107:=MAX(DYNAINFO(3),DYNAINFO(5));

VAR108:=MIN(DYNAINFO(3),DYNAINFO(6));

VAR109:=VAR107-VAR108;

VAR110:=VAR108+VAR109*7/8;

VAR111:=VAR108+VAR109*0.5/8;

DRAWICON(LONGCROSS(VAR111,CLOSE,2),CLOSE,1);

DRAWICON(LONGCROSS(CLOSE,VAR110,2),CLOSE,2);
 

通达信分时主图强大实用手机电脑端可用公式主图源码

下载链接:(下载本站资源请点击下面进入下载页“蓝色图标”)